Re: syscall renaming

Date view Thread view Subject view Author view

From: Godmar Back (gback@cs.utah.edu)
Date: Fri Dec 11 1998 - 20:46:28 EST


 I replaced everything with jmalloc now.
However, you can still rename jmalloc and make it a macro.

jcalloc actually is.

There's also other changes from Jason.
For instance, a simplification for the sysdepCallMethod which I personally
find really nice. It's make the sparc sysdepCallMethod much easier to read.

Besides simplifying things, it might even speed things up for interpreter
applications that call a lot of native methods with no long or double
arguments.

Archie, what do you want to rename things to?
Remember the dprintf fiasco (see the #define in debug.h)

        - Godmar

>
> Godmar Back writes:
> > I'm almost done with malloc, if you want to do the rest that would be great.
>
> OK, I'll wait for your checkin.
>
> One thing though :-)
>
> I was going to replace instaces of malloc() and free() in the code
> with KMALLOC() and KFREE(), which were simply macros:
>
> #define KMALLOC(x) jmalloc
> #define KFREE(p) jfree
> #define KCALLOC(a,b) jmalloc((a)*(b))
>
> The reason is because we may want to do this:
>
> #ifdef DEBUG
>
> #undef KFREE
> #define KFREE(p) do { jfree(p); (p) = (void*)0; } while (0)
>
> #endif
>
> This helps find bogus references through pointers that have been free'd.
>
> -Archie
>
> ___________________________________________________________________________
> Archie Cobbs * Whistle Communications, Inc. * http://www.whistle.com
>


Date view Thread view Subject view Author view

This archive was generated by hypermail 2b29 : Sat Sep 23 2000 - 19:57:12 EDT